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Troubleshoot Jira integration: Unable to export sticky notes
Troubleshoot Jira integration: Unable to export sticky notes
Possible cause and workaround to this error in Jira Cloud and Jira Server.
Jen Butler avatar
Written by Jen Butler
Updated over a week ago

A known limitation when exporting sticky notes to Jira is that, if the project is configured to require certain fields at the moment of issue creation (such as custom fields which aren't supported by the export modal), you won’t be able to export sticky notes to your Jira project. This article walks you through a possible solution!

Note: The steps below are for Jira Cloud instances. The steps for Jira Server are similar, but require a third-party add-on.

Here's how this error may look:

Issue

Possible Cause

Possible Solution

User clicks Send to Jira to send sticky notes, but then sees a pop-up error message that says "We couldn't send to Jira." The error message also lists the required fields.

The only fields we can use when sending a sticky note to Jira are Issue Type, Priority, and Reporter.

If a Jira project has more required fields, you won’t be able to send a sticky note to that project.

Change your project configuration so the other required fields are required after issue creation (see the steps below).

You can move the field validation from issue creation to instead occur at the first transition (for example, moving an issue to in-progress). This way, you can keep your required field validations and can still use the integration.

Pro tip: If you’re able to send sticky notes to other projects in Jira without getting the above error, it’s very likely that there’s an issue with how this specific Jira project is set up.

To change the order of required fields in your Jira Cloud project’s workflow:

  1. Open your Jira instance.

  2. Click the Settings gear in the top right corner of your Jira dashboard.

  3. Select Issues.

  4. Click Workflow schemes in the left sidebar menu.

  5. Click to open the workflow you want to change.

  6. Click the Edit button on the active workflow page.

  7. Make sure you’re on the Diagram view of the workflow.

  8. Click the transition point (arrow) in the workflow where you want to adjust the validation.

  9. Click Validators in the pop-up menu.

  10. Click Add validator.

  11. Select the Field Required Validator option and click Add.

    Note: This option is only inherently available in Jira Cloud. If you have Jira Server, you must install a third-party app.

  12. Add the field(s) required for this transition.

    Note: The only fields you can use when sending a sticky note to Jira are Issue Type, Priority, and Reporter. So, this step is where you’ll add any extra fields that your specific Jira project is configured to require.

  13. (Optional) Add an error message.

  14. Click Add at the bottom of the screen.

Now that you’ve added a validator after the point of issue creation, try to send a sticky note to Jira again. That should solve the problem! If you get stuck, feel free to reach out to Mural support.

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