Introduction

This article offers clear steps for error handling the Jira server integration. There are two types of errors you may encounter during integration: Networking and Authentication.

Networking errors

The three most common Networking errors are:

Not accessible

Here's how the Not accessible error looks:

UI

Error Message

Workspace admins

All other members

Here are some possible causes and solutions for a Not accessible error:

Possible Cause

Possible Solution

There is a typo in the Jira Instance URL.

Make sure the URL is correct.

Your Jira instance is in a protected Intranet, NAT, or behind a firewall.

Contact your IT admin.

Invalid certificate

Here's how the Invalid certificate error looks:

UI

Error Message

Workspace admins

All other members

Here are some possible causes and solutions for an Invalid certificate error:

Possible Cause

Possible Solution

Your Jira Instance's certificate has expired.

Contact your IT admin to check the Jira Instance’s certificate.

There is a typo in the Jira Instance URL.

Make sure the URL is correct.

Partial certificate

Here's how the Partial certificate error looks:

UI

Error Message

Workspace admins

All other members

The Partial certificate error message means that you need to provide a complete certificate in order to connect your Jira instance.

Here’s a possible cause and solution for a Partial certificate error:

Possible Cause

Possible Solution

Your certificate is being emitted by an authority whose certificate is not widely distributed in popular browsers.

Contact your IT admin to check the Jira Instance certificate.

Authentication errors

The Jira Server integration uses the Jira Application Link feature to connect a MURAL workspace and a Jira instance. The OAuth 1.0a protocol performs actions on behalf of the user (such as create Jira issues from stickies).

Here's more information about Jira's authentication protocol.

The three most common Authentication error messages are:

Token rejected

Here's how the Token rejected error looks:

UI

Error Message

All members

Here is a possible cause and solution for a Token rejected error:

Possible Cause

Possible Solution

You or the Jira admin deleted the Application Link without disconnecting the integration in MURAL.

  1. Create a new Application Link or reconfigure the existing Application Link.

  2. Disconnect and reconnect the Jira integration in MURAL.

Invalid signature

Here's how the Invalid signature error looks:

UI

Error Message

Workspace admins

All other members

The Invalid signature error message means there’s an issue with your Application Link. As a reminder: the Jira Server integration uses the Jira Application Link feature to connect MURAL to a Jira instance. More specifically, the integration uses a Public Key.

Here’s a possible cause and solution for an Invalid signature error:

Possible Cause

Possible Solution

The public key was copied with some extra or missing characters. Or, the public key may be missing altogether.

Make sure to copy the complete Public Key and paste it in the Application Link configuration.

Consumer key

Here's how the Consumer key error looks:

UI

Error Message

Workspace admins

All other members

Here are some possible causes and solutions for a Consumer key error:

Possible Cause

Possible Solution

There is a typo in the Consumer key.

Copy the exact Consumer key and paste it in the Application Link configuration.

When you copied and pasted the Consumer key, an extra space or character was also copied and pasted.

Check that the Consumer key you entered matches the Consumer key in our documentation.

You haven’t yet set up the Consumer key or an Application Link for the integration yet.

Check our documentation on how to set up an Application Link.

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